Nikon

BBcode Table Not Working

Recommended Posts

ISSUE: The table BBcode is no longer working and if you try HTML it just does the same, displays the code itself but not the table as it should.

[table]
[tr]
    [th]Member[/th]
    [th]Points[/th]
    [th]Other Info[/th]
[/tr]
[tr]
    [td]John Doe[/td]
    [td]300[/td]
    [td]Test[/td]
[/tr]
[tr]
    [td]Jane Doe[/td]
    [td]100[/td]
    [td]Testing[/td]
[/tr]
[/table]

 

Is there something that needs to be enabled in the configuration or added to it to allow this?

Other BBcode, such as does work so guessing it is just the table code that stopped with the update

Edited by Nikon

Share this post


Link to post
Share on other sites

Nikon, I can't seem to find that configuration anywhere, but I'm having similar troubles with getting my old code back for vote tags in mafia and such things.

 

I'm reading that it is a limitation with the new software, but I'll keep my eyes open on plugins that restore this functionality - if you see any, please let me know via PM.

Share this post


Link to post
Share on other sites

Will do, thanks!

What version of Invision Boards are we running (9?)?  Just so the plug-in is compatible if I find one? 

Edited by Nikon

Share this post


Link to post
Share on other sites

Awesome, will see if I can find anything then.

Share this post


Link to post
Share on other sites

glgl

 

if you find a way to include media bbcode tags like before, I'll love you forever*

 

 

 

 

 

 

 

*maybe just for a day, but still....

Share this post


Link to post
Share on other sites
1 hour ago, Nikon said:

Any way to test this?

https://ckeditor.com/cke4/addon/table

 

Found it suggested for v4 of IPB here

https://invisioncommunity.com/forums/topic/402274-table-bbcode/

 

Will also look for media (what specifics are you looking for)?

 

It says in that same post that it is available within ipb 4.x, which we have now....so I'm not sure if there is a configurable toggle I'm missing somewhere.....

Share this post


Link to post
Share on other sites

^^^^ When I hit reply or start a new post, there's a button called Source at the far left end of the toolbar next to the Bold button. If you click that and paste in your HTML code for a table, then click Source again, it shows up perfectly fine. Like so:-

 

Name  Score Age Attempts
       
       
       

 

I used THIS site to generate the table size I needed very quickly. Perfect for anyone not up on HTML coding. Once it was in the source box, I could add text in the normal view by typing right into the boxes.  Does that help?

Share this post


Link to post
Share on other sites

So you don't get this, Cindy? 

 

SourceButton.JPG

 

Maybe that's set to Admin only. I don't want to go adding functionality that might be a security risk for malicious code. I read that Invision was trying to do away with BBCode by having the IP 4.x boards sort of auto translate code into HTML. (That's my simple translation of what they said btw not a technical explanation by any means.) Wonder if there's a secure way around this by adding another toolbar button, Verb? Limit its use to forum groups possibly? It's under the Settings tab. 

Share this post


Link to post
Share on other sites

Don't have the source button either. :(

 

Is there any way you can grant the ability to only certain people or maybe only to DM staff as well as admins?

Share this post


Link to post
Share on other sites
16 hours ago, Taymist said:

So you don't get this, Cindy? 

 

SourceButton.JPG

 

Maybe that's set to Admin only. I don't want to go adding functionality that might be a security risk for malicious code. I read that Invision was trying to do away with BBCode by having the IP 4.x boards sort of auto translate code into HTML. (That's my simple translation of what they said btw not a technical explanation by any means.) Wonder if there's a secure way around this by adding another toolbar button, Verb? Limit its use to forum groups possibly? It's under the Settings tab. 

 

Not sure....the warnings I read applied to creating a new button for users - it gives people the ability to add malicious code and I can't make that "on" for certain people and "off" for others - it appears to be a total on or off thing for everybody.

Share this post


Link to post
Share on other sites

That is what I read unless the add-on installs a table feature without need for the HTML being enabled... figured it may be worth testing and, worst case, it doesn't work and can be uninstalled. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now